Training - Technology Requirements

Important Message: COVID-19 Impact on Test Centers

To take the interactive online training course, be sure your computer meets minimum requirements by installing one of the following browsers: 

Windows:

  • Internet Explorer 11 or later
  • Firefox (latest version)
  • Google Chrome (latest version)
  • Microsoft Edge (latest version)

Mac:

  • Safari (latest version)
  • Firefox (latest version)
  • Google Chrome (latest version)

If you prefer, you can view the modules in a downloadable Study Guide, available in a PDF format.